User Tools

Site Tools


doc:tools:laser_cutter

Laser Cutter Howto

“Laser Cutting in 10 easy steps (and 10 hard ones)”

(Start on this page if it's your first time using the laser cutter. After that if you're still keen there are Usage Details & Technical Details pages)

Current Known Issues

Laser cutter is currently operating around 25% of capacity. Before repairs are undertaken, do a small test cut first and don't trust any published settings for cutting particular materials.

More details on the technical details page.

Purpose of document

The laser cutter is a bit of a tricky tool to master but this document will take you through the minimum steps to get something lasered.  Once you’ve gotten through these basics, you’ll have a better idea as to how CamBam works and what settings you can change.

Read through this document, do the software steps, then get someone to help you with the actual Laser.

Things to remember

The origin of the laser (the 0,0 point) is in the “top, left” position.  You need to mirror your part in the Y axis to make sense.

You can do parts up to 440mm by 280mm.  Aim for less than that.

Cambam is available from http://CamBam.info

Our custom post processor for Cambam is available from https://github.com/CCHS-Melbourne/CCHS-Member-Essentials/raw/master/Laser%20Cutter/CamBam%20PostProcessor/GRBL_laser.zip and includes a readme file that explains how to install it.

Material choice is important

This document only covers acrylic.  Acrylic is a great learning material.  It vaporises as it gets lasered, it doesn’t catch fire if you over cook it or send out a bunch of dangerous chemicals.  Lets just stick to acrylic. Different colours will need different speeds, keep that in mind.

Start with a DXF

I’m not going to tell you which drawing tool you want to use.  Pick one you’re comfortable with and find a plugin to export your file as dxf.  Start with something simple.  Real simple.  I hear circles and squares are nice this time of year.

The Laser understands Gcode

To get your lovely dxf into the laser, you’ll have to run a CAM tool over it. In this case, CamBam.  Download it from http://CamBam.info and get started with the demo.

Here’s where the whole process gets a bit hairy…

  1. Go to File→Open and load your dxf file.
  2. Create a new Active Layer (Layers are a big part of cambam.  They’re in the left panel, towards the top)
    1. Right click on the text “Layers”
  3. Align your design.
    1. Select your whole design
    2. Go to Edit→Transform→Align
    3. Set X to Left with a value of 5
    4. Set Y to Bottom with a value of 5
    5. Ignore Z
  4. Clean up your lines.
    1. Select your whole design.
    2. Go to Edit→Polylines→Remove Overlaps
    3. Put in a value of 0.01mm
  5. Delete your old layer.
    1. Select it, press delete.
  6. Fit your design to arcs.
    1. Select  your whole design.
    2. Go to Edit→Polylines→Arc Fit
    3. Put in a value of 0.01mm
  7. Create an engrave toolpath for you design
    1. Select your whole design.
    2. Go to Machining→Engrave
    3. Click on ‘Part 1’ in the left hand column
    4. Select the Option “Advanced” in the column.
      1. It’s sorta the bottom section.
    5. Ignore most of these options, there are only 5 you care about.
      1. Depth Increment - Don’t change it, just remember what it is. e.g. 0.4
      2. Target Depth - Make it equal to the Depth Increment, but negative. e.g. -0.4
      3. Cut Feedrate - 200 will cut all the way through.  2000 will engrave.
      4. Spindle Speed - 255 to cut all the way through, 60 to engrave.
      5. Tool Diameter - 0.4
    6. Generate the toolpath
      1. Right click on “Part 1” and go to “Generate Toolpath”
  8. Set a Post Processor
    1. Click on the “Machining” option (It’s just above “Part 1”)
    2. Scroll down until you see the “Post Processor” field
    3. Select “GRBL_laser” from the dropdown box
  9. Generate Toolpaths again (just to be sure)
    1. Right click on the “Machining” option.
    2. Select “Generate Toolpaths”
  10. Produce Gcode
    1. Right click on the “Machining” option.
    2. Select “Produce gcode”
    3. Select a filename, change the extension to “.gcode”.  Remember the location.

Pronterface talks to the Laser

This is where you grab the duty officer or someone with experience to help you.  There’s another page that covers all the little things you need to do to make sure the laser is ready to rumble, but don't try it without help.

Once the laser is powered up, Pronterface is pretty easy.

  1. Once again, grab the duty officer to help.
  2. Click the “Connect” button in the top left of the screen.
  3. Click the “G28” on the top right of the screen (it’s blue).  This makes sure the machine is homed.
  4. Put your material in.
  5. Click the “Load File” button beneath the “connect” one.  Browse to your gcode.
  6. Switch the switch on the Laser to “HVP On”. Lights should light up.
  7. Click the “Print” button.  It’s to the right of the “Load File” button.
  8. Watch the laser goodness until the laser moves back to it’s home position.
  9. Switch the switch on the Laser to “Off”.
  10. Enjoy your laser parts.  Find minute flaws. Go back to step one.

What Next?

Caught the laser cutting bug? usage_details has a lot more detail about material choice, design tools, fancy cutting settings, etc.

doc/tools/laser_cutter.txt · Last modified: 2015/05/04 00:43 by 114.76.61.181